Top Items to Improve Excel Accessibility

*Note: Contains some content from ATI’s Document Accessibility
Fundamentals Course.

Getting Started

1.

6.

Select an accessible template by choosing File>New from
Template. In the window that opens, enter “accessible template”
in the search field, and choose a template that matches the type of
content intended for the spreadsheet.

Enter descriptive names for each worksheet in your workbook, leaving
no blank worksheets.

Be sure to fill in information for the Al cell.

Make sure to organize data in a logical reading order, left to right,
then top to bottom. Avoid spanning information across multiple rows
or columns.

Verify vital information in headers, footers, and watermarks is
duplicated in another part of the document.

Avoid using form fields.

Tables

If you plan to add a table to your spreadsheet, it is important to keep the
table as simple as possible, avoiding split or merged cells, as well as nested
tables. Screen reader software reads tables from left to right, cell by cell,
top to bottom. Concise, straightforward header cell information is critical for
screen readers to navigate the table successfully.

To add a table:

1.

Enter data to be used for the table.

2. Click in a cell within the data.
3. Click on Insert menu and click on the Table button.
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https://support.microsoft.com/en-us/office/video-start-with-an-accessible-excel-template-918db751-1585-41c5-9ddf-5d7a0915afaf
https://support.microsoft.com/en-us/office/video-create-more-accessible-tables-in-excel-86e50f77-0f15-4537-ab1d-62d0e4cd5645
https://www.youtube.com/watch?v=fk93e93PtW8

4. Verify the selected area includes all the data for the table.
5. Ensure "My Table has headers” is checked, and click OK.

Create Table

Where is the data for your table?
$A$1:3C$11 ~
My table has headers

6. Add a descriptive name for the table by clicking any cell within the
table, choose the Table menu, and fill in the table name in the field
under "Table Name.”
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*Please note: The table name must start with a letter or underscore, not
include spaces or unallowed characters, and not conflict with the name of an
existing table in the workbook.

The syntax of this name
isn't correct.

Verify that the name:

-Starts with a letter or underscore (_)
-Doesn't include a space or character
that isn't allowed
-Doesn't conflict with an existing name
in the workbook.

7. Choose an accessible table design by selecting a cell within the table,
and click on the Table menu. Make sure to choose a design with
greater color contrast of rows, as well as the header row.
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8. Increase row height by selecting the entire table, selecting Format,
navigating to Row>Height, increase the row height to, 30 or 40 for
example, and click OK.
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9. Adjust column width by selecting the entire table, going to
Format>Column>AutoFit Selection.
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10. Select a cell in the table, click on the Table menu, and verify the
Header Row and/or First Column are checked.
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Charts

When including a chart in your spreadsheet, it is important to choose labels
for chart elements carefully, as well as include alt text, to help people using
a screen reader to understand the data.

1. Create the chart by selecting the data for the chart, select Insert, and
choose the chart you would like to use.
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2. If you are not sure what would work best, try the "Recommended
Charts” option.
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https://support.microsoft.com/en-us/office/video-create-more-accessible-charts-in-excel-19e81ce7-88af-4a3f-a4ef-a26c344527b3
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Select “"Chart Title” text, and revise it to a meaningful title.

Select Chart Design>Add Chart Element>Axis Titles and choose
either Primary Horizontal or Primary Vertical. In the chart, select the
“Axis Title” and enter a title that clearly describes the axis. If both
axes are used, follow the same steps to label the other axis.
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Select the horizontal or vertical axis, then Format>Format Pane to
adjust the legibility of the axis, including the axis type, axis crosses,
position, tick marks, label position and interval, and humber format.
Check the font format to make sure the font is a light color on a dark
background, or vice versa. Verify the font is a sans serif font, such as
Verdana, and it is at least 12 points or larger.

Add alt text to describe the chart by selecting Review>Check
Accessibility>Alt Text, and click on the chart to access the alt text
field. Alternatively, you can select the chart, right click on it, and
choose “View Alt Text...”
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Fonts

The recommended fonts to use for accessibility are Arial and Verdana. The
best font size to use is 12 pt., anything smaller should not be used.

Note: Avoid the following to communicate meaning or emphasis, as
screen readers will ignore the formatting.

Capitalization

Bold, italics, underlining
Strikethrough
Highlighting

Drop caps

WordArt

Color Choices

Make sure to choose colors that have a greater contrast ratio, so those with
visual impairments will be able to read the document. When there is less
color contrast between the font color and the background color, it is more
difficult for those with visual impairments to read. The below illustration
gives various examples of color contrast, pay close attention to the examples
with a contrast ratio of at least 4.5:1.

Examples of Contrast Ratios
« Blue 12 pt text on white background with ratio of 3.2 to 1

« Red 12 pt text on white background with ratio of 4.3 to 1
Dark red 12 pt text on white background with ratio of 5.7 to 1

Black 12 pt text on white background with ratio of 21.0 to 1

lGreen 12 pt text on black background with ratio of 9.0 to 1

[lYellow 12 pt text on black background with ratio of 12.6 to 1
WWhite 12 pt text on black background with ratio of 18.3 to 1

From ATI Document Accessibility Fundamentals Course

When including illustrations, such as a chart, make sure not to rely on color
alone to communicate meaning. Use another indicator as well, such as
shape or line type, to communicate information.


https://webaim.org/techniques/fonts/
https://youtu.be/L-99RfyMCVU
https://webaim.org/articles/contrast/

Example of an accessible chart

Using the same chart, now color, line type (i.e., dashed, solid), and labels are used to distinguish between each country.
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Happiness Rating

From ATI Document Accessibility Fundamentals Course

Images

When including images in your spreadsheet, also give your images a
description, called alt text, that can be read by a screen reader, to give
information about the image. When possible, avoid images with text, as the
text is unavailable to the screen reader software, and cannot be adjusted
easily by those who may need to alter text elements, such as font size. Also
avoid distracting background images. To enter the alt text information:

1. Right click on the image.
2. Choose View Alt Text from the menu.

Assign Macro...

View Alt Text...

Crop

Auto Crop

Size and Properties...

Format Picture...

3. In the window that appears, enter a 1-2 sentence description of your
image.

Alt Text )

How would you describe this object and its
context to someone who is blind or low
vision?

- The subject(s) in detail

- The setting

- The actions or interactions

- Other relevant information

(1-2 detailed sentences recommended)

Right click menu shown with “View Alt
Text.." option highlighted.

Generate alt text for me

Mark as decorative


https://support.microsoft.com/en-us/office/video-improve-accessibility-with-alt-text-9c57ee44-bb48-40e3-aad4-7647fc1dba51
https://accessibility.huit.harvard.edu/describe-content-images

4. If it is decorative, meaning it does not give information, such as a
border or line, choose Mark as decorative.
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How would you describe this object and its
context to someone who is blind or low
vision?

- The subject(s) in detail

- The setting

- The actions or interactions

- Other relevant information

(1-2 detailed sentences recommended)
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Links

When adding hyperlinks to your spreadsheet, it is important to give each link
a unigue name that identifies how and where a link will open. Screen reader
software provides a list of links, and if each has the same name, or is not
descriptive, the person using screen reader software will not know which link
to choose, or where the link will take them. Make sure to avoid link nhames
such as “"Read More,” “Click Here,” “"Here,” or “Learn More.” To give your link
a unique, descriptive name:

1. Type the word you want to associate with the hyperlink, and then click
away from the cell.
2. Right click the cell, and choose Hyperlink.

Filter >
Sort >
Insert Comment

Format Cells...
Pick From Drop-down List...
Define Name...

Hyperlink...

3. Enter the link in the Address field, and verify a unique, descriptive
name is in the Text to Display field.


https://support.microsoft.com/en-us/office/video-create-accessible-links-in-word-28305cc8-3be2-417c-a313-dc22082d1ee0
https://webaim.org/techniques/hypertext/

Insert Hyperlink
Text to Display:  U.S. Supreme Court ScreenTip...

Web Page or File =~ This Document = Email Address
Link to an existing file or web page.

Address: ;Vhttps://www.supremecourt.gov/ | Sselect...

4. When finished, click OK.

*Please note: If you would like to insert more than one link into a cell, you
will need to implement this workaround, and mark the shapes as decorative
once complete. To do that, follow the same steps as you would to add alt
text to an image.

Save as Picture...
Assign Macro...

View Alt Text...

Set as Default Shape
Size and Properties...
Format Shape...

Document Information

There are three pieces of information that are helpful for screen readers to
find information in the document: Title, Author, and Language. To enter the
Title and Author, go to File>Properties>Summary. When done, click OK.
To enter the document language, go to Tools>Language. Click on the
Language option, make sure English is set as the default, and click OK.
When done, save your document in the .xlIsx file format to retain
accessibility information, and give the document a filename that indicates
the file’s content.

File Format: Excel Workbook (.xIsx) (C]


https://www.youtube.com/watch?v=vlOIM1_2pGI

Document Protection

There should be no protections enabled, so no areas of the spreadsheet are
rendered inaccessible. To check for protections, click on the Review menu,
and select the caret symbol next to Restrict Permissions to verify "No
Restrictions” is checked.
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Checking for accessibility

The next step is to check for accessibility issues. To check accessibility:

1. Click on Review>Check Accessibility.
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Workbook Check Translate
Statistics Accessibility

2. An Accessibility window will open with items to check and correct.
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Inspection Results
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v Review auto-generated alt text
Picture 18
Picture 17

Keep accessibility checker running
while | work

3. After correcting any accessibility issues found, you can close the
window. Alternatively, you can click on the Accessibility status display
at the bottom of your document to open the Accessibility window.

joé Accessibility: Good to go


https://support.microsoft.com/en-us/office/improve-accessibility-with-the-accessibility-checker-a16f6de0-2f39-4a2b-8bd8-5ad801426c7f

Create PDF

The last step is to create a PDF version of your Word document, to allow
people without Word to view your document. To create the PDF:

1. Go to File>Save As.

2. In the Save As field, give your document a name, if the document
name will be different from your Excel document name.

3. Choose a location to save your PDF document to.

4. Choose PDF from the File Format dropdown list, and make sure Best
for electronic distribution and accessibility (uses Microsoft
online service) is selected.

5. Click Export.
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